Returns an interface providing access to shape-driven properties and methods for this Rebar element.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public RebarShapeDrivenAccessor GetShapeDrivenAccessor() |
Visual Basic |
---|
Public Function GetShapeDrivenAccessor As RebarShapeDrivenAccessor |
Visual C++ |
---|
public: RebarShapeDrivenAccessor^ GetShapeDrivenAccessor() |
Return Value
The interface providing access to shape-driven properties and methods for this Rebar element.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This method applies only to shape driven rebar. |