Removes one region in split crop.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public void RemoveSplitRegion( int regionIndex ) |
Visual Basic |
---|
Public Sub RemoveSplitRegion ( _ regionIndex As Integer _ ) |
Visual C++ |
---|
public: void RemoveSplitRegion( int regionIndex ) |
Parameters
- regionIndex
- Type: System..::..Int32
Index of region to be deleted (numbering starts with 0).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The provided region index cannot be deleted. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | The crop of the associated view is not permitted to have multiple regions. -or- The view has non-rectangular crop shape set. |