Creates a filter rule that determines whether strings from the document are less than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2011

Syntax

C#
public static FilterRule CreateLessOrEqualRule(
	ElementId parameter,
	string value,
	bool caseSensitive
)
Visual Basic
Public Shared Function CreateLessOrEqualRule ( _
	parameter As ElementId, _
	value As String, _
	caseSensitive As Boolean _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateLessOrEqualRule(
	ElementId^ parameter, 
	String^ value, 
	bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value against which values from the document will be compared.
caseSensitive
Type: System..::..Boolean
If true, the string comparison will be case-sensitive.

Remarks

For strings, a value is "less" than another if it would appear before the other in an alphabetically-sorted list.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also