The exact length of the curve.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public double Length { get; } |
Visual Basic |
---|
Public ReadOnly Property Length As Double Get |
Visual C++ |
---|
public: property double Length { double get (); } |
Remarks
Computes the length of the curve using analytical or numeric
integration. There is no performance hit for lines and arcs.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the curve is unbound and not periodic. |