For a spiral, the overall height.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public double Height { get; set; } |
Visual Basic |
---|
Public Property Height As Double Get Set |
Visual C++ |
---|
public: property double Height { double get (); void set (double value); } |
Remarks
Applies only to instances where RebarShape.Definition is of type
RebarShapeDefinitionByArc, and its Type property is equal to the value
RebarShapeDefinitionByArcType.Spiral.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: height must be positive. |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This RebarShapeDrivenAccessor is not an instance of a spiral shape. -or- This RebarShapeDrivenAccessor doesn't contain a valid rebar reference. |