Connects two placeholders that looks like Tee connection.
Namespace: Autodesk.Revit.DB.PlumbingAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static bool ConnectPipePlaceholdersAtTee( Document document, ElementId placeholder1Id, ElementId placeholder2Id ) |
Visual Basic |
---|
Public Shared Function ConnectPipePlaceholdersAtTee ( _ document As Document, _ placeholder1Id As ElementId, _ placeholder2Id As ElementId _ ) As Boolean |
Visual C++ |
---|
public: static bool ConnectPipePlaceholdersAtTee( Document^ document, ElementId^ placeholder1Id, ElementId^ placeholder2Id ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document.
- placeholder1Id
- Type: Autodesk.Revit.DB..::..ElementId
The first element Id of pipe placeholder.
- placeholder2Id
- Type: Autodesk.Revit.DB..::..ElementId
The second element Id of pipe placeholder which connects to first.
Return Value
True if connection succeeds, false otherwise.
Remarks
The second placeholder must have physically connection with the first one.
If connection fails, the placeholders cannot be physically connected.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The element id placeholder1Id is not pipe placeholder. -or- The element id placeholder2Id is not pipe placeholder. -or- The elements belong to different types of system. -or- The curve placeholder2Id does not connect on the curve placeholder1Id or vice versa. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |