Creates a CADLinkOptions object, specifying whether to preserve
graphic overrides, and what view to use if the link's view has been
deleted.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public CADLinkOptions( bool preserveOverrides, ElementId viewId ) |
Visual Basic |
---|
Public Sub New ( _ preserveOverrides As Boolean, _ viewId As ElementId _ ) |
Visual C++ |
---|
public: CADLinkOptions( bool preserveOverrides, ElementId^ viewId ) |
Parameters
- preserveOverrides
- Type: System..::..Boolean
True if Revit should preserve the link's graphic overrides on reload. False otherwise.
- viewId
- Type: Autodesk.Revit.DB..::..ElementId
The id of the view to use as the link's reference view, if the reference view has been deleted. Revit will ignore this value if the reference view is still in place.
The value may be ElementId.InvalidElementId, although Revit will cancel the load if the reference view is deleted.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |