Defines whether reinforcement rounding is activated for the particular element.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public bool IsActiveOnElement { get; set; } |
Visual Basic |
---|
Public Property IsActiveOnElement As Boolean Get Set |
Visual C++ |
---|
public: property bool IsActiveOnElement { bool get (); void set (bool value); } |
Remarks
If these overrides relate to ReinforcementSettings, this property is shared for Rebar and Fabric related elements. Toggling this value will toggle the settings for both kinds of Reinforcement elements.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: Reinforcement rounding overrides for this element cannot be enabled because overrides are not enabled for ReinforcementSettings. |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural. |