Creates a new parameter binding between a parameter and a set of categories in a specified group.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public virtual bool Insert( Definition key, Binding item, BuiltInParameterGroup parameterGroup ) |
Visual Basic |
---|
Public Overridable Function Insert ( _ key As Definition, _ item As Binding, _ parameterGroup As BuiltInParameterGroup _ ) As Boolean |
Visual C++ |
---|
public: virtual bool Insert( Definition^ key, Binding^ item, BuiltInParameterGroup parameterGroup ) |
Parameters
- key
- Type: Autodesk.Revit.DB..::..Definition
A parameter definition which can be an existing definition or one from a shared parameters file.
- item
- Type: Autodesk.Revit.DB..::..Binding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.
- parameterGroup
- Type: Autodesk.Revit.DB..::..BuiltInParameterGroup
The GroupID of the parameter definition, or INVALID if the parameter is not to be associated with any predefined group.
Remarks
Note the type of the binding object dictates whether the parameter is bound to all
instances or just types. A parameter definition cannot be bound to both instances and types.
If the Parameter binding already exists, post an error and return false