Creates a new DisplacementPath referencing a DisplacementElement and edge or curve and adds it to the document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public static ElementId Create( Document aDoc, DisplacementElement displacementElement, Reference reference, double param ) |
Visual Basic |
---|
Public Shared Function Create ( _ aDoc As Document, _ displacementElement As DisplacementElement, _ reference As Reference, _ param As Double _ ) As ElementId |
Visual C++ |
---|
public: static ElementId^ Create( Document^ aDoc, DisplacementElement^ displacementElement, Reference^ reference, double param ) |
Parameters
- aDoc
- Type: Autodesk.Revit.DB..::..Document
The document.
- displacementElement
- Type: Autodesk.Revit.DB..::..DisplacementElement
Element id of a DisplacementElement
- reference
- Type: Autodesk.Revit.DB..::..Reference
A reference that refers to an edge or curve of one of the elements displaced by the displacementElement.
- param
- Type: System..::..Double
A value in the range [0,1]. It will be interpreted as a parameter for the specified edge.
Return Value
The element id of the newly created DisplacementPath.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The value param should lie in the range [0,1]. -or- reference does not represent an edge or curve belonging to an element displaced by displacementElement. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |