Gets the user-visible name for a BuiltInParameter in a specific LanguageType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2020

Syntax

C#
public static string GetLabelFor(
	BuiltInParameter builtInParam,
	LanguageType language
)
Visual Basic
Public Shared Function GetLabelFor ( _
	builtInParam As BuiltInParameter, _
	language As LanguageType _
) As String
Visual C++
public:
static String^ GetLabelFor(
	BuiltInParameter builtInParam, 
	LanguageType language
)

Parameters

builtInParam
Type: Autodesk.Revit.DB..::..BuiltInParameter
The BuiltInParameter to get the user-visible name.
language
Type: Autodesk.Revit.ApplicationServices..::..LanguageType
The desired LanguageType to get the user-visible name in.

Return Value

The BuiltInParameter name in the desired LanguageType.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..InvalidOperationException Thrown when the BuiltInParameter cannot be found.
Autodesk.Revit.Exceptions..::..InvalidOperationException Thrown when the desired LanguageType cannot be found for the BuiltInParameter name.

See Also