The class is used as base class for the arguments of any pre-event arguments that is associated to a particular Document.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public class PreDocEventArgs : PreEventArgs
Visual Basic
Public Class PreDocEventArgs _
	Inherits PreEventArgs
Visual C++
public ref class PreDocEventArgs : public PreEventArgs

Inheritance Hierarchy

System..::..Object
  System..::..EventArgs
    Autodesk.Revit.DB.Events..::..RevitEventArgs
      Autodesk.Revit.DB.Events..::..PreEventArgs
        Autodesk.Revit.DB.Events..::..PreDocEventArgs

See Also