Identifies if the element has been pinned to prevent changes.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public bool Pinned { get; set; } |
Visual Basic |
---|
Public Property Pinned As Boolean Get Set |
Visual C++ |
---|
public: property bool Pinned { bool get (); void set (bool value); } |
Remarks
An element which is pinned may not be moved, and warnings will be issued
when an attempt is made to delete it.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: Element cannot be pinned or unpinned. |