The default offset used to determine the outer perimeter to be divided into zones.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public double CoreOffset { get; set; } |
Visual Basic |
---|
Public Property CoreOffset As Double Get Set |
Visual C++ |
---|
public: property double CoreOffset { double get (); void set (double value); } |
Remarks
A Zone can be either a Mass Zone or an Analytical Space depending on whether the AnalysisType is ConceptualMasses or otherwise.
Specifying a value here determines the zone depth and creates a core zone.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for coreOffset must be between 0 and 30000 feet. |