Sets the structural section in element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public void SetStructuralSection( StructuralSection structuralSection ) |
Visual Basic |
---|
Public Sub SetStructuralSection ( _ structuralSection As StructuralSection _ ) |
Visual C++ |
---|
public: void SetStructuralSection( StructuralSection^ structuralSection ) |
Parameters
- structuralSection
- Type: Autodesk.Revit.DB.Structure.StructuralSections..::..StructuralSection
Structural section with values that will be set.
Remarks
Only beams, braces and structural columns can have a structural section.
To check if the element can have structural section use the [!:Family.HasStructuralSection()] method.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FamilySymbol cannot have a structural section. |