Indicates if the material used for the graphical appearance is by category or a specific material, or
if the material to be used should be taken from the ConceptualConstructionType of the MassLevelData.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public MassSurfaceDataMaterialType MaterialType { get; set; } |
Visual Basic |
---|
Public Property MaterialType As MassSurfaceDataMaterialType Get Set |
Visual C++ |
---|
public: property MassSurfaceDataMaterialType MaterialType { MassSurfaceDataMaterialType get (); void set (MassSurfaceDataMaterialType value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The material type does not fall within an appropriate range. |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |