Constrain the length of a segment by parameterizing its length.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void AddConstraintParallelToSegment(
int iSegment,
ElementId paramId,
bool measureToOutsideOfBend0,
bool measureToOutsideOfBend1
) |
Visual Basic |
---|
Public Sub AddConstraintParallelToSegment ( _
iSegment As Integer, _
paramId As ElementId, _
measureToOutsideOfBend0 As Boolean, _
measureToOutsideOfBend1 As Boolean _
) |
Visual C++ |
---|
public:
void AddConstraintParallelToSegment(
int iSegment,
ElementId^ paramId,
bool measureToOutsideOfBend0,
bool measureToOutsideOfBend1
) |
Parameters
- iSegment
- Type: System..::..Int32
Index of the segment (0 to NumberOfSegments - 1).
- paramId
- Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter to drive the constraint. To obtain the id of a shared parameter,
call RebarShape.GetElementIdForExternalDefinition().
- measureToOutsideOfBend0
- Type: System..::..Boolean
Choose between two possibilities for the first reference of the length dimension. If false, the reference is at the point where the bend begins; equivalently, at the projection of the bend centerpoint onto the segment. If true, the reference is moved outward by a distance equal to the bend radius plus the bar diameter; if the bend is a right angle or greater, this is equivalent to putting the reference at the outer face of the bend.
- measureToOutsideOfBend1
- Type: System..::..Boolean
Choose between two possibilities for the second reference of the length dimension.
Exceptions
See Also