Creates a new part list multicategory schedule assembly view for the assembly instance.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public static ViewSchedule CreatePartList( Document document, ElementId assemblyInstanceId, ElementId viewTemplateId, bool isAssigned ) |
Visual Basic |
---|
Public Shared Function CreatePartList ( _ document As Document, _ assemblyInstanceId As ElementId, _ viewTemplateId As ElementId, _ isAssigned As Boolean _ ) As ViewSchedule |
Visual C++ |
---|
public: static ViewSchedule^ CreatePartList( Document^ document, ElementId^ assemblyInstanceId, ElementId^ viewTemplateId, bool isAssigned ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document to which the view will be added.
- assemblyInstanceId
- Type: Autodesk.Revit.DB..::..ElementId
Id of the assembly instance that owns the new view.
- viewTemplateId
- Type: Autodesk.Revit.DB..::..ElementId
Id of the view template that is used to create the view; if invalidElementId, the view will be created with the default settings.
- isAssigned
- Type: System..::..Boolean
If true, the template will be assigned, if false, the template will be applied.
Return Value
A new part list multicategory schedule assembly view.
Remarks
The new part list schedule will be preloaded with fields "Category", "Family and Type" and "Count".
The document must be regenerated before using the schedule.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | assemblyInstanceId is not an AssemblyInstance. -or- viewTemplateId is not a correct view template for the schedule view. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction. |