Verifies if the KeyBasedTreeEntry could be added in this KeyBasedTreeEntriesLoadContent.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public bool CanAddEntry( KeyBasedTreeEntry entry ) |
Visual Basic |
---|
Public Function CanAddEntry ( _ entry As KeyBasedTreeEntry _ ) As Boolean |
Visual C++ |
---|
public: bool CanAddEntry( KeyBasedTreeEntry^ entry ) |
Parameters
- entry
- Type: Autodesk.Revit.DB..::..KeyBasedTreeEntry
The KeyBasedTreeEntry object to be checked.
Return Value
True if the KeyBasedTreeEntry could be added in, otherwise false.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |