Removes a coping (cut) from a steel beam.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public bool RemoveCoping( FamilyInstance cutter ) |
Visual Basic |
---|
Public Function RemoveCoping ( _ cutter As FamilyInstance _ ) As Boolean |
Visual C++ |
---|
public: bool RemoveCoping( FamilyInstance^ cutter ) |
Parameters
- cutter
- Type: Autodesk.Revit.DB..::..FamilyInstance
A steel beam or column for which this beam currently has a coping cut. May not be nullNothingnullptra null reference (Nothing in Visual Basic) or itself.
Remarks
This function corresponds to Tools -> Remove coping in Revit Structure.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when 'cutter' is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when 'cutter' refers to this instance. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration fails. |