Gets the local coordinate system (LCS) reflects analytical model orientation at the specified point.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2015
Syntax
Visual Basic |
---|
Public Function GetLocalCoordinateSystem ( _
point As XYZ _
) As Transform |
Visual C++ |
---|
public:
Transform^ GetLocalCoordinateSystem(
XYZ^ point
) |
Return Value
Transformation matrix.
- x - longitudinal axis,
- y - transversal, section - horizontal, strong axis,
- z - transversal, section - vertical, weak axis,
- origin - base point of LCS.
Exceptions
See Also