Get References to all Faces of the MassEnergyAnalyticalModel which are of Mass Shade subcategory.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public IList<Reference> GetReferencesToAllShadingFaces() |
Visual Basic |
---|
Public Function GetReferencesToAllShadingFaces As IList(Of Reference) |
Visual C++ |
---|
public: IList<Reference^>^ GetReferencesToAllShadingFaces() |
Return Value
Array of Reference to Faces that represent Mass Shades.
Remarks
Called out as a separate convenience method because often it is more useful to obtain
information about non-shading faces from the zones, and only get information about shading faces
from the MassEnergyAnalyticalModel.