Define a ReferencePoint relative to a referenceable edge or
curve on another element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public class PointOnEdge : PointElementReference |
Visual Basic |
---|
Public Class PointOnEdge _ Inherits PointElementReference |
Visual C++ |
---|
public ref class PointOnEdge : public PointElementReference |
Remarks
The ReferencePoint's X basis vector is constrained to the
tangent vector to the curve. The Y and Z vectors are free to rotate
around the curve.