Whether the definition stores the parameter.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2009
Syntax
C# |
---|
public bool HasParameter( ElementId paramId ) |
Visual Basic |
---|
Public Function HasParameter ( _ paramId As ElementId _ ) As Boolean |
Visual C++ |
---|
public: bool HasParameter( ElementId^ paramId ) |
Parameters
- paramId
- Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter.
Return Value
True if the definition stores the parameter, false otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |