Identifies if a hook type is permitted for this bar type
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public bool GetHookPermission( ElementId hookId ) |
Visual Basic |
---|
Public Function GetHookPermission ( _ hookId As ElementId _ ) As Boolean |
Visual C++ |
---|
public: bool GetHookPermission( ElementId^ hookId ) |
Parameters
- hookId
- Type: Autodesk.Revit.DB..::..ElementId
id of the hook type
Return Value
True if the hook type is permitted for this bar type, otherwise false
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | the rebar hook type id hookId is not valid |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |