The rounding for Bar Length and Total Bar Length parameters.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public double TotalLengthRounding { get; set; } |
Visual Basic |
---|
Public Property TotalLengthRounding As Double Get Set |
Visual C++ |
---|
public: property double TotalLengthRounding { double get (); void set (double value); } |
Remarks
IsActiveOnElement property has to be true. TotalLengthRounding is meaningless if IsActiveOnElement is false.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The given value for value is not a number |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The rounding value is not a positive value. |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: IsActiveOnElement property is false. |