Gets the ids of all elements which are external file references.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static ICollection<ElementId> GetAllExternalFileReferences( Document aDoc ) |
Visual Basic |
---|
Public Shared Function GetAllExternalFileReferences ( _ aDoc As Document _ ) As ICollection(Of ElementId) |
Visual C++ |
---|
public: static ICollection<ElementId^>^ GetAllExternalFileReferences( Document^ aDoc ) |
Parameters
- aDoc
- Type: Autodesk.Revit.DB..::..Document
A Revit Document.
Return Value
The ids of all elements which are external file references.
Remarks
This function will not return the ids of nested Revit links;
it only returns top-level references.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |