Gets the clipping planes for the Revit view where rendering takes place. Clipping planes control the 3D extent of a view and can be set using Section Box in Revit.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2017

Syntax

C#
public static IList<ClipPlane> GetClipPlanes()
Visual Basic
Public Shared Function GetClipPlanes As IList(Of ClipPlane)
Visual C++
public:
static IList<ClipPlane^>^ GetClipPlanes()

Return Value

The array of clipping planes, which is empty if none are set.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..InvalidOperationException This DrawContext is not available because Revit is not currently rendering. In general, this DrawContext must be used in the scope of the RenderScene() callback of IDirectContext3DServer.

See Also