Converts the geometry stored in the external format into a collection of Revit geometry objects.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2017
Syntax
Visual Basic |
---|
Public Function Convert ( _
document As Document, _
filename As String _
) As IList(Of GeometryObject) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The Revit document where the resulting Revit geometry objects will be used. This document may need to be modified
to store dependent elements such as graphics styles and/or materials.
- filename
- Type: System..::..String
The full path to the input file.
Return Value
A collection of Revit geometry objects created from the incoming data.
Exceptions
See Also