Retrieve one geometric primitive representing given subelement.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public GeometryObject GetGeometryObject( View dbView ) |
Visual Basic |
---|
Public Function GetGeometryObject ( _ dbView As View _ ) As GeometryObject |
Visual C++ |
---|
public: GeometryObject^ GetGeometryObject( View^ dbView ) |
Parameters
- dbView
- Type: Autodesk.Revit.DB..::..View
The view for view-specific geometry or nullNothingnullptra null reference (Nothing in Visual Basic) for model geometry.
Return Value
The geometric object representing this subelement.
Remarks
In case of whole element, geometric object representing element and its subelements will be returned.
nullNothingnullptra null reference (Nothing in Visual Basic) will be returned if related geometric object could not be found in the model.