Gets the user-visible name for a UnitSymbolType.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
[ObsoleteAttribute("This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `GetLabelForSymbol(ForgeTypeId)` method instead.")] public static string GetLabelFor( UnitSymbolType unitSymbolType ) |
Visual Basic |
---|
<ObsoleteAttribute("This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `GetLabelForSymbol(ForgeTypeId)` method instead.")> _ Public Shared Function GetLabelFor ( _ unitSymbolType As UnitSymbolType _ ) As String |
Visual C++ |
---|
[ObsoleteAttribute(L"This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `GetLabelForSymbol(ForgeTypeId)` method instead.")] public: static String^ GetLabelFor( UnitSymbolType unitSymbolType ) |
Parameters
- unitSymbolType
- Type: Autodesk.Revit.DB..::..UnitSymbolType
The UnitSymbolType to get the user-visible name.
Remarks
The name is obtained in the current Revit language.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Symbol must have a definition. UST_NONE and UST_CUSTOM are not allowed. |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |