Add a new type of wire material.
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public WireMaterialType AddWireMaterialType( string name, WireMaterialType baseMaterial ) |
Visual Basic |
---|
Public Function AddWireMaterialType ( _ name As String, _ baseMaterial As WireMaterialType _ ) As WireMaterialType |
Visual C++ |
---|
public: WireMaterialType^ AddWireMaterialType( String^ name, WireMaterialType^ baseMaterial ) |
Parameters
- name
- Type: System..::..String
Name of new material type.
- baseMaterial
- Type: Autodesk.Revit.DB.Electrical..::..WireMaterialType
Specify an existing material type which New material will be constructed based on.