Validates geometry to be stored in a DirectShape. Suitable geometry validation is performed. Additionally, the geometry
must make sense as a shape representation for the category assigned to this DirectShape object.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2015
Syntax
C# |
---|
public bool IsValidGeometry(
Solid Geom
) |
Visual Basic |
---|
Public Function IsValidGeometry ( _
Geom As Solid _
) As Boolean |
Visual C++ |
---|
public:
bool IsValidGeometry(
Solid^ Geom
) |
Return Value
True if the supplied GeometryObject passes the validation criteria.
Exceptions
See Also