Sets the line pattern id associated with this category for the given graphics style type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public void SetLinePatternId( ElementId linePatternId, GraphicsStyleType graphicsStyleType ) |
Visual Basic |
---|
Public Sub SetLinePatternId ( _ linePatternId As ElementId, _ graphicsStyleType As GraphicsStyleType _ ) |
Visual C++ |
---|
public: void SetLinePatternId( ElementId^ linePatternId, GraphicsStyleType graphicsStyleType ) |
Parameters
- linePatternId
- Type: Autodesk.Revit.DB..::..ElementId
The line pattern id for the graphics style.
- graphicsStyleType
- Type: Autodesk.Revit.DB..::..GraphicsStyleType
The type of graphics style.
Remarks
- The line pattern id will be one of the following:
- A negative value (representing a built-in line pattern); this value can only be obtained via GetLinePatternId
- The id of a LinePatternElement
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument "linePatternId" is an illegal id. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when this category does not have stored line pattern id for this graphics style type. |