The ElementIds of other MassEnergyAnalyticalModels that are "joined" to this one.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public ICollection<ElementId> GetJoinedMassEnergyAnalyticalModelElementIds() |
Visual Basic |
---|
Public Function GetJoinedMassEnergyAnalyticalModelElementIds As ICollection(Of ElementId) |
Visual C++ |
---|
public: ICollection<ElementId^>^ GetJoinedMassEnergyAnalyticalModelElementIds() |
Return Value
ElementIds of other MassEnergyAnalyticalModels that are joined to this one.
Remarks
Joined MassEnergyAnalyticalModels are created off of mass instances that are joined and which both
have MassLevelData's associated. Only MassEnergyAnalyticalModels which are joined will take each
other into account when regenerating surface subcategories for their Faces. For example, if two
MassEnergyAnalyticalModels were adjacent but not joined, both their touching faces would be treated
as "Mass Exterior Wall", instead of "Mass Interior Wall". This situation (touching things not being
joined) because mass instances, and as a result, corresponding MassEnergyAnalyticalModel's are
automatically joined and only become unjoined if the user unjoins them.