Contains markers and text settings for analysis display style element.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public class AnalysisDisplayMarkersAndTextSettings : IDisposable |
Visual Basic |
---|
Public Class AnalysisDisplayMarkersAndTextSettings _ Implements IDisposable |
Visual C++ |
---|
public ref class AnalysisDisplayMarkersAndTextSettings : IDisposable |
Examples

// Settings relating to the marker shape and size and the display of values AnalysisDisplayMarkersAndTextSettings markerSettings = new AnalysisDisplayMarkersAndTextSettings(); markerSettings.MarkerSize = .05; markerSettings.MarkerType = AnalysisDisplayStyleMarkerType.Triangle; markerSettings.Rounding = .01; // Settings relating to the marker color AnalysisDisplayColorSettings colorSettings = new AnalysisDisplayColorSettings(); colorSettings.MaxColor = new Color(255, 0, 0); colorSettings.MinColor = new Color(0, 255, 255); // Settings relating to the legend AnalysisDisplayLegendSettings legendSettings = new AnalysisDisplayLegendSettings(); legendSettings.Rounding = .01; // Create the new display style AnalysisDisplayStyle ads = AnalysisDisplayStyle.CreateAnalysisDisplayStyle(doc, "Markers 1", markerSettings, colorSettings, legendSettings); // Assign the new display style to the current view doc.ActiveView.AnalysisDisplayStyleId = ads.Id;

' Settings relating to the marker shape and size and the display of values Dim markerSettings As New AnalysisDisplayMarkersAndTextSettings() markerSettings.MarkerSize = 0.05 markerSettings.MarkerType = AnalysisDisplayStyleMarkerType.Triangle markerSettings.Rounding = 0.01 ' Settings relating to the marker color Dim colorSettings As New AnalysisDisplayColorSettings() colorSettings.MaxColor = New Color(255, 0, 0) colorSettings.MinColor = New Color(0, 255, 255) ' Settings relating to the legend Dim legendSettings As New AnalysisDisplayLegendSettings() legendSettings.Rounding = 0.01 ' Create the new display style Dim ads As AnalysisDisplayStyle = AnalysisDisplayStyle.CreateAnalysisDisplayStyle(doc, "Markers 1", markerSettings, colorSettings, legendSettings) ' Assign the new display style to the current view
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB.Analysis..::..AnalysisDisplayMarkersAndTextSettings
Autodesk.Revit.DB.Analysis..::..AnalysisDisplayMarkersAndTextSettings