Creates a new geometric arc object based on center, radius, unit vectors, and angles.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public static Arc Create( XYZ center, double radius, double startAngle, double endAngle, XYZ xAxis, XYZ yAxis ) |
Visual Basic |
---|
Public Shared Function Create ( _ center As XYZ, _ radius As Double, _ startAngle As Double, _ endAngle As Double, _ xAxis As XYZ, _ yAxis As XYZ _ ) As Arc |
Visual C++ |
---|
public: static Arc^ Create( XYZ^ center, double radius, double startAngle, double endAngle, XYZ^ xAxis, XYZ^ yAxis ) |
Parameters
- center
- Type: Autodesk.Revit.DB..::..XYZ
The center of the arc.
- radius
- Type: System..::..Double
The radius of the arc.
- startAngle
- Type: System..::..Double
The start angle of the arc (in radians).
- endAngle
- Type: System..::..Double
The end angle of the arc (in radians).
- xAxis
- Type: Autodesk.Revit.DB..::..XYZ
The x axis to define the arc plane. Must be normalized.
- yAxis
- Type: Autodesk.Revit.DB..::..XYZ
The y axis to define the arc plane. Must be normalized.
Return Value
The new arc.
Remarks
If the angle range is equal to or greater than 2 * PI, the curve will be
automatically converted to an unbounded circle.
Examples

// Create a new arc defined by its center, radios, angles and 2 axes double radius = 10; double startAngle = 0; // In radian double endAngle = Math.PI; // In radian XYZ center = new XYZ(5, 0, 0); XYZ xAxis = new XYZ(1, 0, 0); // The x axis to define the arc plane. Must be normalized XYZ yAxis = new XYZ(0, 1, 0); // The y axis to define the arc plane. Must be normalized Arc arc = Arc.Create(center, radius, startAngle, endAngle, xAxis, yAxis);

' Create a new arc defined by its center, radios, angles and 2 axes Dim radius As Double = 10 Dim startAngle As Double = 0 ' In radian Dim endAngle As Double = Math.PI ' In radian Dim center As New XYZ(5, 0, 0) Dim xAxis As New XYZ(1, 0, 0) ' The x axis to define the arc plane. Must be normalized Dim yAxis As New XYZ(0, 1, 0) ' The y axis to define the arc plane. Must be normalized Dim arc__1 As Arc = Arc.Create(center, radius, startAngle, endAngle, xAxis, yAxis)
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | xAxis is not length 1.0. -or- yAxis is not length 1.0. -or- The given value for radius must be between 0 and 30000 feet. |
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | The vectors xAxis and yAxis are not perpendicular. -or- Start angle must be less than end angle. -or- Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance). |