Constructs a new instance of a filter to match family instances by structural usage,
with the option to match all family instances which are not of the given structural usage.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public StructuralInstanceUsageFilter( StructuralInstanceUsage structuralUsage, bool inverted ) |
Visual Basic |
---|
Public Sub New ( _ structuralUsage As StructuralInstanceUsage, _ inverted As Boolean _ ) |
Visual C++ |
---|
public: StructuralInstanceUsageFilter( StructuralInstanceUsage structuralUsage, bool inverted ) |
Parameters
- structuralUsage
- Type: Autodesk.Revit.DB.Structure..::..StructuralInstanceUsage
The structural usage to match.
- inverted
- Type: System..::..Boolean
True if the filter should match all family instances which are not of the given structural usage.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |