Retrieves the deck embedding type used for the specified structural deck.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public StructDeckEmbeddingType GetDeckEmbeddingType( int layerIdx ) |
Visual Basic |
---|
Public Function GetDeckEmbeddingType ( _ layerIdx As Integer _ ) As StructDeckEmbeddingType |
Visual C++ |
---|
public: StructDeckEmbeddingType GetDeckEmbeddingType( int layerIdx ) |
Parameters
- layerIdx
- Type: System..::..Int32
Index of a layer in the CompoundStructure.
Return Value
The embedding type of the structural deck associated to the specified layer. Invalid if it is not a structural deck.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range. |