The unit of measure for imported geometry.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public ImportUnit Unit { get; set; } |
Visual Basic |
---|
Public Property Unit As ImportUnit Get Set |
Visual C++ |
---|
public: property ImportUnit Unit { ImportUnit get (); void set (ImportUnit value); } |
Remarks
Units are used to calculate the import scale unless scale is defined explicitly using CustomScale, in which case Units will be ignored.
Feet, inches, meters, centimeters, decimeters, millimeters are all supported. If Default unit is set, Revit will read and use the units from the file. If units are not available or accessible there, Revit will default to inches.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |