Returns the number of the edge on the other Rebar Element to which this RebarConstraint is attached.
The RebarConstraint must be of RebarConstraintType 'ToOtherRebar,' and the TargetRebarConstraintType
must be 'Edge.'
Rebar must be Shape Driven Rebar element.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2014
Syntax
C# |
---|
public int GetTargetRebarEdgeNumber() |
Visual Basic |
---|
Public Function GetTargetRebarEdgeNumber As Integer |
Visual C++ |
---|
public:
int GetTargetRebarEdgeNumber() |
Exceptions
Exception | Condition |
---|
Autodesk.Revit.Exceptions..::..InvalidOperationException |
RebarConstraint is no longer valid.
-or-
The RebarConstraint is not of RebarConstraintType 'ToOtherRebar.'
-or-
The RebarConstraint is not attached to an edge, or bend, or hook bend of another Rebar Element.
-or-
Constrained rebar is a free form rebar element.
|
See Also