Retrieves an id of a rule for a given index in the list.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public PerformanceAdviserRuleId GetRuleId( int index ) |
Visual Basic |
---|
Public Function GetRuleId ( _ index As Integer _ ) As PerformanceAdviserRuleId |
Visual C++ |
---|
public: PerformanceAdviserRuleId^ GetRuleId( int index ) |
Parameters
- index
- Type: System..::..Int32
The index to retrieve the rule id for.
Return Value
The rule id.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The index is outside of acceptable range. |