Retrieves the item that is the current focus of the iterator.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public virtual Object Current { get; } |
Visual Basic |
---|
Public Overridable ReadOnly Property Current As Object Get |
Visual C++ |
---|
public: virtual property Object^ Current { Object^ get (); } |
Implements
IEnumerator..::..Current
Remarks
A new or Reset iterator must have MoveNext called on it before Current will return a valid
item as per expected behavior of IEnumerator.