The description for the originating Revit element.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public string OriginatingElementDescription { get; } |
Visual Basic |
---|
Public ReadOnly Property OriginatingElementDescription As String Get |
Visual C++ |
---|
public: property String^ OriginatingElementDescription { String^ get (); } |
Remarks
Surface and Opening elements get an CADObjectId element assigned
according to the below described schema, based on associative
room bounding element:
(Family Name): (Family Type)[Element Id]
Sample: System Panel: System Panel [50566]