Used to determine whether the element supports the given parameter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public static bool IsParameterApplicable( Element element, ElementId parameter ) |
Visual Basic |
---|
Public Shared Function IsParameterApplicable ( _ element As Element, _ parameter As ElementId _ ) As Boolean |
Visual C++ |
---|
public: static bool IsParameterApplicable( Element^ element, ElementId^ parameter ) |
Parameters
- element
- Type: Autodesk.Revit.DB..::..Element
The element to query for support of the given parameter.
- parameter
- Type: Autodesk.Revit.DB..::..ElementId
The parameter for which to query support.
Return Value
True if the element supports the given parameter, false otherwise.
Remarks
This operation is supported for external (e.g., shared, project)
parameters only.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |