Identifies if provided assembly members are valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2012

Syntax

C#
public static bool AreElementsValidForAssembly(
	Document document,
	ICollection<ElementId> assemblyMemberIds,
	ElementId assemblyId
)
Visual Basic
Public Shared Function AreElementsValidForAssembly ( _
	document As Document, _
	assemblyMemberIds As ICollection(Of ElementId), _
	assemblyId As ElementId _
) As Boolean
Visual C++
public:
static bool AreElementsValidForAssembly(
	Document^ document, 
	ICollection<ElementId^>^ assemblyMemberIds, 
	ElementId^ assemblyId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
assemblyMemberIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Element ids to be tested for validity for membership of an assembly instance.
assemblyId
Type: Autodesk.Revit.DB..::..ElementId
Id of the existing assembly to add components to. If invalid, the method return whether the components can be added to a new assembly

Return Value

True if all member ids are valid, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also