Create an opening to cut the wall or ceiling.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
Parameters
- host
- Type: Autodesk.Revit.DB..::..Element
Host elements that new opening would lie in. The host can only be a wall or a ceiling.
- profile
- Type: Autodesk.Revit.DB..::..CurveArray
The profile of the newly created opening. This may contain more
than one curve loop. Each loop must be a fully closed curve loop and the loops may not
intersect. The profiles will be projected into the host plane.
Return Value
If successful, the newly created opening is returned, otherwise an
exception with error information will be thrown.
Exceptions
See Also