Unlabels a dimension that is currently labeled by this global parameter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016 Subscription Update
Syntax
C# |
---|
public void UnlabelDimension( ElementId dimensionId ) |
Visual Basic |
---|
Public Sub UnlabelDimension ( _ dimensionId As ElementId _ ) |
Visual C++ |
---|
public: void UnlabelDimension( ElementId^ dimensionId ) |
Parameters
- dimensionId
- Type: Autodesk.Revit.DB..::..ElementId
Id of a dimension element.
Remarks
It is assumed that the given dimension element is presently labeled
by this parameter. If it is not, this method throws an exception.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Given element Id is not of a valid dimension element. -or- The given dimension (dimensionId) is not labeled by this global parameter. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |