Add an edge to the form, connecting two edges on same/different profile, by a pair of specified edge/param.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void AddEdge(
Reference startEdgeReference,
double startParam,
Reference endEdgeReference,
double endParam
) |
Visual Basic |
---|
Public Sub AddEdge ( _
startEdgeReference As Reference, _
startParam As Double, _
endEdgeReference As Reference, _
endParam As Double _
) |
Visual C++ |
---|
public:
void AddEdge(
Reference^ startEdgeReference,
double startParam,
Reference^ endEdgeReference,
double endParam
) |
Parameters
- startEdgeReference
- Type: Autodesk.Revit.DB..::..Reference
The geometry reference of start edge
- startParam
- Type: System..::..Double
The param on start edge to specify the location.
- endEdgeReference
- Type: Autodesk.Revit.DB..::..Reference
The geometry reference of end edge
- endParam
- Type: System..::..Double
The param on end edge to specify the location.
See Also