Removes member element ids from the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2012

Syntax

C#
public void RemoveMemberIds(
	ICollection<ElementId> memberIds
)
Visual Basic
Public Sub RemoveMemberIds ( _
	memberIds As ICollection(Of ElementId) _
)
Visual C++
public:
void RemoveMemberIds(
	ICollection<ElementId^>^ memberIds
)

Parameters

memberIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Element ids to be removed from the assembly instance.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException One or more element ids was not permitted to be removed from the assembly instance. Provided set should not be empty and all elements should be a member of the assembly instance. -or- The provided set includes one or more element ids that cannot be added to or removed from the assembly on their own.
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also